Z-Offset für Auto-Leveling Einstellen
Werbung

Falls Ihr euch schon gefragt habt ob man jedesmal beim Auto-Leveling Sensor an den Drucker muss um dann erst im Menü rumfuchtelt bis man dann endlich den Z-Offset einstellen kann.. Nö muss nicht sein. Hier ein Kleines Tutorial !

  • Startet euren Drucker
  • Heizt Hotbed und Hotend auf tatsächliche Drucktemperatur
  • Entfernt jeglichen Dreck vom Hotbed und Hotend !
  • Sendet einen G-Code Befehl per Cura, S3D, Octoprint etc. an den Drucker -> “G28” für ein Home ALL
  • Nach “Home All” legt ihr ein Stück Papier unter die Noozle und geht per Interface solange in -0.1 oder -1.0 Schritten runter bis das Papier an der Noozle kratzt.
  • Notiert jetzt den Wert am Drucker der bei “Z” steht. z.B. -1.66
  • Jetzt den G-Code Befehl “M851” benutzen um die Eprom werte auszulesen, dort ist eine Zeile der mit “M851” anfängt. z.B. M851 Z-0.10
  • Rechnet EUREN “Z” Wert mit dem M851 Wert zusammen ! z.B. -1.66 + -0.10 = -1.76
  • Sendet nun den neuen Wert per G-Code Befehl an das Board “M851 Z-1.76
  • Sichert das ganze per G-Code Befehl “M500” in den Eprom !
  • Sendet nochmal den G-Code Befehl “G28” und legt danach ein Papier darunter und geht nochmals solange mit -0.1 oder -1.0 runter bis an eurem Drucker Z0 steht. Wenn
  • jetzt das Papier so ist wie ihr es haben wolltet ist alles eingestellt !

Startseite Foren Z-Offset für Auto-Leveling Einstellen

Dieses Thema enthält 13 Antworten und 4 Teilnehmer. Es wurde zuletzt aktualisiert von  Sonny vor 6 Monate, 2 Wochen.

Login Registrieren
  • Autor
    Beiträge
  • #1101 Antwort

    dd!
    Keymaster

    Falls Ihr euch schon gefragt habt ob man jedesmal beim Auto-Leveling Sensor an den Drucker muss um dann erst im Menü rumfuchtelt bis man dann endlich
    [See the full post at: http://plastikjunkies.de/z-offset-fuer-auto-leveling-einstellen/]

  • #1637 Antwort

    Joachim D.

    Guten Abend, bin noch ein Neuling auf dem Gebiet des 3D-Druckes. Ich hab die Anleitung befolgt. Hab da aber ne vielleicht blöde Frage: auf dem Display des Druckers steht kein explizites “-” bei Z. Auch kann ich nicht tiefer als “000” leveln. Wie bekomme ich die  Nozzle tiefer??

    Danke schon mal im Voraus!!

    • #1643 Antwort

      t0bse
      Keymaster

      wie bewegst du Z denn? auf dem Display des Druckers oder per Terminal?

  • #1752 Antwort

    paD

    Hi Zusammen,

    ich habe ein kleines Problem – und zwar habe ich einen LJC18A3-H-Z/BX verbaut. Die Firmware usw. hat Problemlos funktioniert.

    Wenn ich dieser Anleitung folge, kann ich das ganze immer und immer (und immer…..) wieder machen. Nachdem ich das erste mal eingestellt habe, und den Sensor danach auf Home fahre (G28) – ist es immer wieder falsch eingestellt.

    Ich fahre also die Z-Achse soweit runter das ein Blatt so gerade dazwischen passt, speichere, fahre auf Home, fahre wieder auf “Z 0” und siehe da, mal klemmt das Blatt fest, mal bekomme ich drei Blatt dazwischen .. es ist immer unterschiedlich.

    Habt ihr Erfahrungen woran das liegen kann? Er übernimmt die Werte anstandslos. Auch nach einem Neustart sind die Werte korrekt vorhanden.. Fahre ich auf Home und danach die Z-Achse auf 0 – nicht mehr der gleiche Abstand..

    Jetzt sind meine Ideen: Der Sensor schaltet mal früher mal später – oder die Z-Achse fährt nicht korrekt. Das die Z-Achse nicht korrekt fährt, schließe ich aber fast aus, da ich ohne Sensor problemlos drucken kann..

    Würde mich freuen, wenn ihr noch eine Idee habt 🙂

    PS: Habe den Anet A8 mit Glas-Plattem upgrade 🙂

    • #1753 Antwort

      t0bse
      Keymaster

      ist dein heizbett immer gleich heiss?

      ansonsten mal heizbett abschalten und auf g28 fahren und danach wieder einschalten… wir haben auch einen beitrag dazu: http://plastikjunkies.de/kapazitiver-sensor-ungenau-das-muss-nicht-sein/

      • Diese Antwort wurde geändert vor 2 Jahre, 5 Monate von  t0bse.
    • #1755 Antwort

      paD
      Teilnehmer

      Hey,

      hm.. das könnte tatsächlich das Problem sein. Ich werde es mal testen.

      Hab schon mal reichlich dank für deine Hilfe ?

      paD

    • #1756 Antwort

      paD

      Was soll ich sagen? 3 Drucke, 3 mega First-Layer. So hatte ich mir das mit dem Sensor vorgestellt.

      Der Beitrag gehört einfach unter jedem Beitrag mit dem Autoleveln bei beheizten Betten 😉

      Top, Danke!

  • #3702 Antwort

    Basti

    Seit einer Woche habe ich den Sensor an meinem Drucker.

    Ich muss mich der Frage von Joachim vom letzten Jahr leider anschließen.

    Soweit so gut, aber ich kann den richtigen  M851  Offset nur erraten, oder wie kann man den Drucker dazu bewegen manuell in den negativen Bereich zu fahren um den Papiertest zu machen?

    Trotz M500 sind der Offset nach jedem Neustart des Druckers bzw. Systems (Drucker + Pi mit Octoprint verschwunden. Ich habe den M851 Befehl jetzt in das Startscript von Octoprint gepackt, aber ist das so richtig?

    Drucker BQ Hepestos i3 FW 2.51

    • #3825 Antwort

      Flo

      Um in den negativen Bereich zu fahren, muss in der Configuration.h folgendes auskommentiert werden:

      #define MIN_SOFTWARE_ENDSTOPS

  • #3926 Antwort

    Cesar 2018

    Hi folgende Frage.

    Und zwar habe ich einen Anet A6 und habe ihn auf Auto bed leveling umgebaut spricht Skynet hochgeladen und co. Aber normalerweise sollte der Sensor nur angehen (spricht die Led) wenn er das Bed fast berührt. Aber bei mir schaltet er sich bei Berührung aus und bei entfernung an. Habe schon einen neuen Sensor bestellt aber ich will nicht so lange warten. Deswegen ist meine Frage wie man die Schalt Situation umkehrt.

     

    Also bitte so schnell wie möglich mir helfen würde mich darüber wansenig freuen.

  • #3927 Antwort

    Cesar 2014

    Hi folgende Frage.

    Und zwar habe ich einen Anet A6 und habe ihn auf Auto bed leveling umgebaut spricht Skynet hochgeladen und co. Aber normalerweise sollte der Sensor nur angehen (spricht die Led) wenn er das Bed fast berührt. Aber bei mir schaltet er sich bei Berührung aus und bei entfernung an. Habe schon einen neuen Sensor bestellt aber ich will nicht so lange warten. Deswegen ist meine Frage wie man die Schalt Situation umkehrt.

     

    Also bitte so schnell wie möglich mir helfen würde mich darüber wansenig freuen.

    • #4375 Antwort

      Ralf

      Dein Problem ist vermutlich schon erledigt aber der Vollständigkeit halber hier noch die Lösung: Du musst die Logic für die Z-Endschalter in der configuration.h umdrehen.

      define Z_MIN_ENDSTOP_INVERTING = false/true

      define Z_MIN_PROBE_ENDSTOP_INVERTING = false/true

      …also false durch true ersetzen.

  • #4390 Antwort

    Andreas

    Hallo, hab da eine Frage

     

    Ich habe einen Anet A8 mit Skynet 2.3.2 und AutoLevelSensor LJ18A3-8-Z/BX vorne links.

    Hat auch tadellos funktioniert Homing in Bettmitte und Autolevel. Beim 5. Druck machte er das Homing richtig und beim Leveln fuhr er in das Bett. Von da an schaltet der Sensor nicht mehr. Ok, dachte die Diode N4148 defekt, getauscht. Software getauscht, kein Erfolg. Hab jetzt die Marlin 1.1.8.

    Zufällig fand ich raus das der Sensor schaltet wenn ich AutoLevel ausgeschaltet habe. Wenn Autolevel eingeschaltet dann schaltet der Sensor zwar korrekt aber der Z-Motor stoppt nicht. Ohne Autolevel funktioniert es.

    Vielleicht hat da einer ja eine Lösung für das Problem.

     

    Danke mal im Vorraus

     

  • #6606 Antwort

    Sonny
    • Ist ja allas toll. Und wie stelle ich das in der Firmware ein?

    Macht das der Drucker automatisch?

     

Login Registrieren
Antwort auf: Z-Offset für Auto-Leveling Einstellen
Deine Information: